The Energy Detective Forums
May 23, 2018, 09:39:52 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: New TED Support forum launched!!
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: ECC Polling API: spyder XML data for Port 4 and 5 transposed
shorn
Newbie
*
Posts: 2


« on: November 13, 2017, 05:40:53 PM »

I am using the ECC Polling API to request data from the ECC in XML format for use by a 3rd party home automation app. I have found that the load data for ports 4 and 5 seem to be transposed. That is, to get the data for port 4 I need to request port 5 data and vice versa. I have not tested to see if the same is true for the csv or raw formatted output. Not a serious issue since there is no apparent loss of data. But in response to my support request, they suggested I post the issue here. Has anyone encountered this, or found other issues with the polling APIs data?
Logged
pfletch101
Sr. Member
****
Posts: 418


WWW
« Reply #1 on: November 14, 2017, 10:20:52 AM »

I cannot confirm the channel transposition you report for the CSV or RAW data. I don't use the XML data because it has much more overhead, but I get the Spyder data that I ask for! I wonder if it is the third party app that is causing the problem. Does Footprints show the respective channels' data as you expect? Otherwise, you should probably check that the Spyder CTs are not switched!

I did report a number of other quirks of the polling API in an old thread here. See http://forum.theenergydetective.com/index.php/topic,2953.0.html.
Logged

Peter R. Fletcher
TED Pro Home - main MTUs monitoring utility and PV Solar feeds; 2 Spyders monitoring selected individual circuits
shorn
Newbie
*
Posts: 2


« Reply #2 on: November 15, 2017, 01:39:24 PM »

The transposed data I am seeing is the raw XML return info, well before the parsing and use by the 3rd party app. The footprints spyder data is correct. Based on your reply, it appears that only the XML extract by the ECC in response to the API request for port 4 and 5 is the problem.
Logged
pfletch101
Sr. Member
****
Posts: 418


WWW
« Reply #3 on: November 15, 2017, 11:44:55 PM »

Based on my understanding of how the data is stored and handled internally, it would take some very weird code to produce this transposition, only affecting XML output , and also only affecting two specific channels - almost certainly not something that could result from any likely coding error. Are you absolutely sure that the CTs are not transposed on the circuits in the breaker box, so that the Footprints display is also reversed?

{Added 09:20 CST 11/16/2017}
I have now looked at the XML downloads (of hour data only, since it would have been too time-consuming to sort through a huge amount of higher frequency data in two channels which (in my setup) are only 'on' rather infrequently) for my Spyder channels 4 and 5, and have confirmed that they are not transposed - the XML data corresponds to that shown for the respective channels in Footprints and in Raw and CSV downloads, and to the power being drawn from the circuits to which the CTs are connected.
« Last Edit: November 16, 2017, 10:29:32 AM by pfletch101 » Logged

Peter R. Fletcher
TED Pro Home - main MTUs monitoring utility and PV Solar feeds; 2 Spyders monitoring selected individual circuits
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.16 | SMF © 2011, Simple Machines Valid XHTML 1.0! Valid CSS!